Aller au contenu principal

Version majeure 2022

Les mises à jour liées à la sécurité et à l'infrastructure sont indiquées par mesure de transparence mais n'entraînent aucun changement visible à votre niveau.

v2022.0.8- 27/06/2022

🐛 Corrigé

  • Certains domaines d'enseignement n'étaient pas présents dans l'export LSU pour certaines classes d'élèves qui étaient déjà présent au cycle 2 dans Opencomp (CP, CE1, CE2) mais désormais au cycle 3 (CM1, CM2). Le logiciel déterminait à tort le cycle de l'élève comme cycle 2 au lieu de cycle 3 et les domaines d'enseignement propres au cycle 3 étaient donc ignorés. C'est désormais corrigé ! (merci à Aude 👍).

v2022.0.7- 19/06/2022

🐛 Corrigé

  • Correction d'une anomalie empêchant la saisie du niveau de maîtrise des compétences numériques.

v2022.0.6- 15/05/2022

🐛 Corrigé

  • Correction d'une anomalie empêchant le chargement d'images en utilisant la fonctionnalité de "glisser-déposer" sur l'éditeur d'exercices.

v2022.0.5 - 11/05/2022

🐛 Corrigé

  • Correction d'une anomalie empêchant la sélection des champs de saisie dans les fenêtres modales des outils de l'éditeur d'exercice (insertion de Séyès, insertion d'images, etc.)

v2022.0.4 - 29/04/2022

🐛 Corrigé

  • Correction d'une anomalie empêchant le chargement de l'éditeur d'exercices.

v2022.0.3 - 25/04/2022

🔄 Dépendances

  • Mise à jour des dépendances backend ⚙️
  • Mise à jour des dépendances frontend 🎨

🐛 Corrigé

  • Le lien permettant de consulter les notes de version pointe désormais vers la nouvelle page Version majeure 2022.

v2022.0.2 - 24/04/2022

🐛 Corrigé

  • Correction d'erreurs Javascript qui pouvaient se produire lors de la saisie des résultats et du niveau de maîtrise des compétences numériques à la souris.

v2022.0.1 - 22/04/2022

🐛 Corrigé

  • Correction des routes vers le plugin AcademicEdition pour permettre le téléchargement correct des fichiers d'export LSU (.xml)

  • Corrections esthétiques mineures (marges d'affichage) sur les vues liées à l'export vers LSU.

v2022.0.0 - 20/04/2022

🔄 Dépendances

  • Mise à jour du langage de script PHP vers la version 8.1.x
  • Mise à jour du cadriciel CakePHP vers la branche 4.3.x
  • Mise à jour du cadriciel Bootstrap vers la branche 5.x
  • Remplacement de la bibliothèque toastr.js par sweetalert2
  • Mise à jour des dépendances backend ⚙️
  • Mise à jour des dépendances frontend 🎨

✨ Amélioré

  • Adaptation du code pour remédier à plusieurs dépréciations introduites avec la version 4.3.x du cadriciel CakePHP.